• 13-07-2019, 18:33:32
    #1
    -- --------------------------------------------------------

    --
    -- Tablo için tablo yapısı `wpa8_wpcc_urls`
    --

    CREATE TABLE `wpa8_wpcc_urls` (
    `id` bigint(20) UNSIGNED NOT NULL,
    `post_id` bigint(20) NOT NULL,
    `url` varchar(2560) COLLATE utf8mb4_unicode_520_ci NOT NULL,
    `thumbnail_url` varchar(2560) COLLATE utf8mb4_unicode_520_ci DEFAULT NULL,
    `category_id` mediumint(9) NOT NULL,
    `is_saved` tinyint(1) NOT NULL DEFAULT 0,
    `saved_post_id` bigint(20) UNSIGNED DEFAULT NULL,
    `update_count` int(10) UNSIGNED NOT NULL DEFAULT 0,
    `is_locked` tinyint(4) NOT NULL DEFAULT 0,
    `created_at` datetime DEFAULT '0000-00-00 00:00:00',
    `updated_at` datetime DEFAULT '0000-00-00 00:00:00',
    `saved_at` datetime DEFAULT NULL,
    `recrawled_at` datetime DEFAULT NULL,
    `deleted_at` datetime DEFAULT NULL
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_520_ci


    resim olarak : http://prntscr.com/oejpqe

    sitemi cpanelden pleske taşırken bu hatayı aldım.
  • 13-07-2019, 18:34:49
    #2
    Kimlik doğrulama veya yönetimden onay bekliyor.
    utf8mb4_unicode_520_ci kısımlarını utf8_unicode_ci olarak değiştirin.

    CREATE TABLE `wpa8_wpcc_urls` (
    `id` bigint(20) UNSIGNED NOT NULL,
    `post_id` bigint(20) NOT NULL,
    `url` varchar(2560) COLLATE utf8_unicode_ci NOT NULL,
    `thumbnail_url` varchar(2560) COLLATE utf8_unicode_ci DEFAULT NULL,
    `category_id` mediumint(9) NOT NULL,
    `is_saved` tinyint(1) NOT NULL DEFAULT 0,
    `saved_post_id` bigint(20) UNSIGNED DEFAULT NULL,
    `update_count` int(10) UNSIGNED NOT NULL DEFAULT 0,
    `is_locked` tinyint(4) NOT NULL DEFAULT 0,
    `created_at` datetime DEFAULT '0000-00-00 00:00:00',
    `updated_at` datetime DEFAULT '0000-00-00 00:00:00',
    `saved_at` datetime DEFAULT NULL,
    `recrawled_at` datetime DEFAULT NULL,
    `deleted_at` datetime DEFAULT NULL
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci
    Hata: Unknown utf8mb4_unicode_520_ci collate
    Türkçesi: utf8mb4_unicode_520_ci karakter tablosu bulunamadı/bilinmiyor.

    Demek ki utf8mb4 karakter kodlaması sunucuda aktif değil. O zaman çözüm en uygun/yakın karakter kodlamasını seçerek, sorguyu düzenlemek ya da sunucuya utf8mb4_ karakter setlerini utf8mb4_unicode_520_ci'de içinde olacak şekilde yüklemek. Bu yüklemeyi sadece SSH erişiminiz varsa yapabilirsiniz.
  • 13-07-2019, 18:36:59
    #3
    Üyeliği durduruldu
    Sql dosyanızı indirip utf8mb4_unicode_520_ci kısımlarını utf8_turkish_ci yapın.
  • 13-07-2019, 18:41:20
    #4
    Solutions adlı üyeden alıntı: mesajı görüntüle
    Sql dosyanızı indirip utf8mb4_unicode_520_ci kısımlarını utf8_turkish_ci yapın.
    Unicode alanı, turkish_ci yapmak doğru bir yaklaşım değil. Tabloda tutulacak verilerin global veya yerel olup olmadığı belli değil. Tablonun doğal yapısı nedeniyle utf8_unicode_ci'ye dönüştürmek daha mantıklı bir yaklaşım olur. Zaten Türkçe karakterli tablolarda bile general_ci ya da unicode_ci kullanmak gerekiyor. Bu collationlar zaten içerisinde Türkçe karakterleri barındırıyorlar.
  • 13-07-2019, 18:44:20
    #5
    Üyeliği durduruldu
    codev adlı üyeden alıntı: mesajı görüntüle
    Unicode alanı, turkish_ci yapmak doğru bir yaklaşım değil. Tabloda tutulacak verilerin global veya yerel olup olmadığı belli değil. Tablonun doğal yapısı nedeniyle utf8_unicode_ci'ye dönüştürmek daha mantıklı bir yaklaşım olur. Zaten Türkçe karakterli tablolarda bile general_ci ya da unicode_ci kullanmak gerekiyor. Bu collationlar zaten içerisinde Türkçe karakterleri barındırıyorlar.
    Geçici bir çözüm olarak problem yaratmayacaktır.
    Diger türlü ise taşıma yapmadan veritabanından yapı değiştirip sonra dışarı aktarmak olur.
  • 13-07-2019, 18:46:30
    #6
    codev adlı üyeden alıntı: mesajı görüntüle
    utf8mb4_unicode_520_ci kısımlarını utf8_unicode_ci olarak değiştirin.

    CREATE TABLE `wpa8_wpcc_urls` (
    `id` bigint(20) UNSIGNED NOT NULL,
    `post_id` bigint(20) NOT NULL,
    `url` varchar(2560) COLLATE utf8_unicode_ci NOT NULL,
    `thumbnail_url` varchar(2560) COLLATE utf8_unicode_ci DEFAULT NULL,
    `category_id` mediumint(9) NOT NULL,
    `is_saved` tinyint(1) NOT NULL DEFAULT 0,
    `saved_post_id` bigint(20) UNSIGNED DEFAULT NULL,
    `update_count` int(10) UNSIGNED NOT NULL DEFAULT 0,
    `is_locked` tinyint(4) NOT NULL DEFAULT 0,
    `created_at` datetime DEFAULT '0000-00-00 00:00:00',
    `updated_at` datetime DEFAULT '0000-00-00 00:00:00',
    `saved_at` datetime DEFAULT NULL,
    `recrawled_at` datetime DEFAULT NULL,
    `deleted_at` datetime DEFAULT NULL
    ) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci
    Hata: Unknown utf8mb4_unicode_520_ci collate
    Türkçesi: utf8mb4_unicode_520_ci karakter tablosu bulunamadı/bilinmiyor.

    Demek ki utf8mb4 karakter kodlaması sunucuda aktif değil. O zaman çözüm en uygun/yakın karakter kodlamasını seçerek, sorguyu düzenlemek ya da sunucuya utf8mb4_ karakter setlerini utf8mb4_unicode_520_ci'de içinde olacak şekilde yüklemek. Bu yüklemeyi sadece SSH erişiminiz varsa yapabilirsiniz.

    hocam şimdide bu hatayı verdi ama : http://prntscr.com/oejucr



    Solutions adlı üyeden alıntı: mesajı görüntüle
    Sql dosyanızı indirip utf8mb4_unicode_520_ci kısımlarını utf8_turkish_ci yapın.
    sizinkini de denedim hata aldım hocam.
  • 14-07-2019, 01:57:32
    #7
    kadersiz35 adlı üyeden alıntı: mesajı görüntüle
    hocam şimdide bu hatayı verdi ama : http://prntscr.com/oejucr





    sizinkini de denedim hata aldım hocam.
    Yazdığınız kod verdiğim kod ile birebir aynı değil. Verdiğim kodu deneyin hocam. CHARSET kısmını utf8mb4 olarak bırakmışsınız.