hostgator sorunumu neden çözemeiyor?
dün chatten iki arkadaşla görüştüm. ikisi de sorunumu açık birşekilde ifade etmeme ve anlamalarına rağmen sorunu çözemedi yanlış anlaşılmasın ben de hostgator kullanıyorum ve şuana kadar hep tavsiye ettim kötülemek amacı ile yazmıyorum bunları ama teknik destekde hizmet veren kişilerin bu tür sorunları rahatlıkla çözebilmeleri de gerekmiyor mu? bana daha yeni kurulmuş drupal sitesi için öyle kaynak vs harcamıyor. vps öneriyorlar. Sorun da şu
Fatal error: Maximum execution time of 30 seconds exceeded in
hostgator bu sorunu neden çözemedi
6
●684
- 04-02-2010, 15:48:02Bu sorun scriptinizle ilgili büyük ihtimalle. 30 saniye boyunca işlem yapan bir sorgu yada döngü nedeniyle yapıyor olabilir. Ki bir scriptin 30 saniye boyunca bir sorguyu yada php döngüsünü bitirememesi sunucuyu oldukça yoracaktır.
- 04-02-2010, 16:53:13Sorunun cevabi su;
PHP settings that cannot be changed:
PHP has been configured to use the following settings on our shared and reseller servers:
safe mode = off
memory_limit = 64M MAXIMUM
max_execution_time = 30 MAXIMUM
post_max_size = 64M MAXIMUM
upload_max_filesize = 64M MAXIMUM
enable_dl = Off
The above settings either CANNOT be changed or cannot be exceeded on a shared and reseller account. These limits are set to prevent extremely high resource usage in shared environments. We have found that a majority of the PHP scripts will work within these limits, and the scripts that require more resources are best suited for a dedicated server. Dedicated servers can have their limits raised to any value required.
Yani su anlama geliyor, yukarida bulunan degerler shared serverlarde degistirilemiyor. - 05-02-2010, 21:26:36sefa seni chatte sordum ama denk gelemedik. diğer arkadaşlar yardımcı olmaya çalıştılar. ancak durum şu; site daha daha önce sorunsuz çalışıyordu. birden bu hatayı vermeye başladı.sence şimdi ne yapmam gerekir benim. vps yada dedicated servera geçmem saçma olur bir site için hele ki daha hiti olmayan bir site için. basit bir yolu yöntemi vardır herhalde php.ini dosyası oluşturup düzenlemekten bahsediyorlar. bu işe yararmı?
- 06-02-2010, 12:17:49Üyeliği durdurulduphp.ini yi değişmeleri gerek ama yapmazlar. Fakat drupal sadece localde wamp yada mamp programlarında bu hatayı verir buda programdan kaynaklanır. Hostlarda bu sıkıntıyı yaşatmaz. hostgatorda bende drupal kullanıyorum hiç sıkıntı yaşamadım hatta gayet memnunum.