Wordpress - Kalıcı bağlantı sorunu - R10.net
  • 13-09-2019, 16:59:41
    #1
    Arkadaşlar merhaba.
    Yeni kurduğum Wordpress sitemde bir sorun yaşıyorum.
    Açılış sayfasını sabit sayfa kullandım ve kalıcı bağlantıları /%postname%/ yaptım.
    İçerikleri yükledikten sonra sitenin güvenliği için Wordfence eklentisi kurdum ve normal tarama yaptım, Sonra bir sorunla karşılaştım ve eklentiyi silmek zorunda kaldım. Daha sonra anasayfam 404 hatası vermeye başladı. Sebebini araştırdım ve birşey buldum. Kalıcı bağlantıları /%post_id%/ yaptığımda açıldığını gördüm. Ancak o zaman da seo'da sıkıntı yaşıyorum. Çözüm olabileceğini umduğum birkaç şey denedim

    • .htaccess dosyasına kalıcı bağlantıları düzeltmek için kod ekledim olmadı, tekrar eski haline getirdim.
    • Temayı değiştim olmadı.
    • Veritabanında wordfence ile ilgili bütün tabloları sildim olmadı
    • Anasayfayı blog sayfası yapıyorum açılıyor ama sabit sayfa yapınca yine açılmıyor.
    • Bu konuyla alakası var mı bilmiyorum ama FTP den dosyaları bilgisayara indirirken ha bire bağlantı kesiliyor.
    Wordfence eklentisi kurana kadar herşey normaldi. çok fazla içerik yükledim. Şimdi komple silip yeniden kurmak çok zamanımı alacak. Lütfen biri yardım etsin.
  • 14-09-2019, 08:38:55
    #3
    Psyduck adlı üyeden alıntı
    PM atarsanız ücretli olarak yardımcı olabilriim.
    İlgine teşekkür ederim dostum ancak bu iş için para almıyorum. Toplum yararı için yapılmış bir site. Ben de elimden geldikçe destek olmaya çalışan biriyim. O yüzden para kazanmadığım bir iş için para harcamak hiç mantıklı gelmiyor. Kimse yardım etmezse kapını çalarım.
  • 14-09-2019, 15:37:14
    #4
    post_id şeklinde açılıyorsa aklıma htaccess ile alakalı olabileceği geldi. Eklenti yüklemeden önceki hali gibi denedin mi? (tarayıcıların önbelleği seni yanıltmasın, farklı tarayıcılardan veya temzileyi unutma) Örn;

    Alıntı
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    Ayrıca dosya ve klasör izinlerini kontrol edebiirsin chmod değerlerini.
  • 14-09-2019, 15:39:23
    #5
    htaccess dosyasını bir silin önce. Wordfence bir ayar esnasında htaccesse'e yazmak istiyor, eklentyiyi kaldırınca ondan dolayı sorun oluş olabilir.
    ALANADLARI * NET SATIŞTA | ACELEKREDI * COM | 10-11 YAŞINDA COM İSİMLER | 9 YAŞINDA ?HABER.COM | 7 YAŞINDA JENERİK NAKLİYAT.?? | ATATURK ONLINE
  • 14-09-2019, 15:39:28
    #6
    restsam adlı üyeden alıntı
    Arkadaşlar merhaba.
    Yeni kurduğum Wordpress sitemde bir sorun yaşıyorum.
    Açılış sayfasını sabit sayfa kullandım ve kalıcı bağlantıları /%postname%/ yaptım.
    İçerikleri yükledikten sonra sitenin güvenliği için Wordfence eklentisi kurdum ve normal tarama yaptım, Sonra bir sorunla karşılaştım ve eklentiyi silmek zorunda kaldım. Daha sonra anasayfam 404 hatası vermeye başladı. Sebebini araştırdım ve birşey buldum. Kalıcı bağlantıları /%post_id%/ yaptığımda açıldığını gördüm. Ancak o zaman da seo'da sıkıntı yaşıyorum. Çözüm olabileceğini umduğum birkaç şey denedim
    • .htaccess dosyasına kalıcı bağlantıları düzeltmek için kod ekledim olmadı, tekrar eski haline getirdim.
    • Temayı değiştim olmadı.
    • Veritabanında wordfence ile ilgili bütün tabloları sildim olmadı
    • Anasayfayı blog sayfası yapıyorum açılıyor ama sabit sayfa yapınca yine açılmıyor.
    • Bu konuyla alakası var mı bilmiyorum ama FTP den dosyaları bilgisayara indirirken ha bire bağlantı kesiliyor.
    Wordfence eklentisi kurana kadar herşey normaldi. çok fazla içerik yükledim. Şimdi komple silip yeniden kurmak çok zamanımı alacak. Lütfen biri yardım etsin.
    Selam dostum;

    PM İletirsen yardımcı olabilirim. Sevgilerimle
    myblogtr.com > cevapservisi.com > seotoolop.com
  • 16-09-2019, 09:29:49
    #7
    Akar adlı üyeden alıntı
    htaccess dosyasını bir silin önce. Wordfence bir ayar esnasında htaccesse'e yazmak istiyor, eklentyiyi kaldırınca ondan dolayı sorun oluş olabilir.
    Dediğin gibi .htaccess dosyasını sildim. eski dosyanın aynısını sistem yeniden oluşturdu. ancak düzelme olmadı. İlgine teşekkür ederim.



    bondcemil adlı üyeden alıntı
    post_id şeklinde açılıyorsa aklıma htaccess ile alakalı olabileceği geldi. Eklenti yüklemeden önceki hali gibi denedin mi? (tarayıcıların önbelleği seni yanıltmasın, farklı tarayıcılardan veya temzileyi unutma) Örn;



    Ayrıca dosya ve klasör izinlerini kontrol edebiirsin chmod değerlerini.
    Öncelikle ilgine teşekkür ederim.
    Söylediğin şeyi denedim. Ancak izinlerde sıkıntı yok gibi. Anasayfa PAGE seçiliyken;
    Kalıcı bağlantıları %post_id% yaptığımda site normal açılıyor.
    Kalıcı bağlantıları %post_name% yaptığımda ve anasayfayı BLOG olarak ayarladığımda da sorunsuz çalışıyor.

    Ancak kalıcı bağlantıları %post_name% yaptığımda ve anasayfayı PAGE ayarladığımda ise;
    "Sayfa yükleme sorunu." başlığı ile
    "Sayfa doğru bir şekilde yönlendirilmiyor
    Bağlantı sırasında bir hata oluştu.
    Bu sorun bazen çerezlerin devre dışı bırakılmasından veya reddedilmesinden kaynaklabilir.
    " hata mesajı çıkıyor. diğer tarayıcıları da denedim, onlarda da aynı sorun görünüyor.

    Tüm WP dosyalarını sildim yeniden yükledim. Temayı ve eklentileri de sildim ve yeniden yükledim. PHPMyAdminde wordfence eklentisinin bıraktığı kalıntıları sildim.
    wp-include/function.php dosyasını elle yapılandırdım. Yine anasayfa açılmadı.
    Birkaç tane permalik eklentisi kurdum. bu seferde anasayfa açılıyor ama alt sayfa linkleri yazıya dönüştüğü için site bozuluyor. O yüzden her sayfaya elle kalıcı bağlantı oluşturmam gerekiyor ama bu da mümkün değil.





    Çok şükür hallettim. Ücret karşılığı yapmak isteyen arkadaşlara da derinden sevgilerimi iletiyorum.
    Sorunu çözmek için bir yıllık VDS ücreti isteyenler bile oldu. Bu kadar fırsatçılık olmaz ya.
    1 haftadır uğraşıyordum. Yukarıda yazdığım herşeyi denedim. Sonunda aklıma gelmeyen biryerden çıktı ve çok basit olduğunu gördüm.

    İhtiyacı olan meslektaşlarımın faydalanması için bu sorunun çözümünü paylaşıyorum.
    Türkçe domain ile wordpress kurulurken site url'sini türkçe yazmayın.
    Mesela benim domainimde (palandöken) yazısı vardı. Wordpress kurulumunu bu şekilde yazarak yaptım. Ancak sorun yaşadım. Daha sonra PHPMyAdmin'de options tablosundaki site url kısmını ve domainin geçtiği tüm satırları (xn--palandken-57a) şeklinde düzelttim ve tüm sayfalar takır takır açıldı.