sanal sunucu ssh den hernangi bir modul kurmaya calıstıgımda sorun la karşılasıyorum
aldıgım hata bu
./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for python3.6... no
checking for python3... no
checking for python... python
checking for --enable-universalsdk... no
checking for --with-universal-archs... no
checking MACHDEP... linux
checking for --without-gcc... no
checking for --with-icc... no
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: in `/root/Python-3.6.0':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details
bu sorunu nasıl çözebilirim
sanal sunucu ssh den hernangi bir modul kurmaya calıstıgımda sorun la karşılasıyorum
8
●225
- 25-04-2018, 17:43:52
- 25-04-2018, 17:49:43Hocam selamlar
Gereksinimleri de kurmanız gerekiyor
yum -y install groupinstall 'Development Tools' gcc gcc-devel libxml2-devel libxslt-devel gd-devel
DestekShell adlı üyeden alıntı: mesajı görüntüle - 25-04-2018, 18:51:58huseyincengiz adlı üyeden alıntı: mesajı görüntüle
hüseyin bey sındıde boyle bı hata ıle karşılasdım bunu nasıl cozebılırım peki
yum -y install groupinstall 'Development Tools' gcc gcc-devel libxml2-devel libxslt-devel gd-devel
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
http://vault.centos.org/6.x/os/x86_6...ta/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: base. Pl ease verify its path and try again - 25-04-2018, 19:06:28Hocam
nano /etc/resolv.conf
nameserver 8.8.8.8
nameserver 8.8.4.4
nano /etc/yum.repos.d/CentOS-Base.repo
baseurl=http://mirror.centos.org/centos/6.9/os/i386/
olmadı /etc/yum.repos.d/CentOS-Base.repo buradaki içeriği yazın düzenliyeyim
DestekShell adlı üyeden alıntı: mesajı görüntüle - 25-04-2018, 19:13:16huseyincengiz adlı üyeden alıntı: mesajı görüntüle
# CentOS-Base.repo
#
# The mirror system uses the connecting IP address of the client and the
# update status of each mirror to pick mirrors that are updated to and
# geographically close to the client. You should use this for CentOS updates
# unless you are manually picking other mirrors.
#
# If the mirrorlist= does not work for you, as a fall back you can try the
# remarked out baseurl= line instead.
#
#
[base]
name=CentOS-$releasever - Base
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
#baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
#released updates
[updates]
name=CentOS-$releasever - Updates
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates
#baseurl=http://mirror.centos.org/centos/$releasever/updates/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
#additional packages that may be useful
[extras]
name=CentOS-$releasever - Extras
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=extras
#baseurl=http://mirror.centos.org/centos/$releasever/extras/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
#additional packages that extend functionality of existing packages
[centosplus]
name=CentOS-$releasever - Plus
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=centosplu s
#baseurl=http://mirror.centos.org/centos/$releasever/centosplus/$basearch/
gpgcheck=1
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5
#contrib - packages by Centos Users
[contrib]
name=CentOS-$releasever - Contrib
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=contrib
#baseurl=http://mirror.centos.org/centos/$releasever/contrib/$basearch/
gpgcheck=1
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-5 - 25-04-2018, 19:15:12Hocam peki centos kaç kullanıyorsun cat /etc/*release*
çıktısını yazabilir misin
- 25-04-2018, 19:16:03huseyincengiz adlı üyeden alıntı: mesajı görüntüle
cat /etc/*release*
cat: /etc/lsb-release.d: Is a directory
CentOS release 5.11 (Final)
32 bit kullanıyorum