Çoğu zaman, web sitenizdeki boş ekran, 500 Internal Server gibi tipik hatalarla karşılaşabilirsiniz. Bu gibi durumlarda, sorunun nedenini tespit etmek için, hata ayıklama bilgilerini almak için hata ayıklama modunu etkinleştirmeniz gerekebilir .

Hata ayıklama modunu etkinleştirmeden önce, CCC'yi (Birleştir, Sıkıştır ve Önbellek) ve Smarty önbelleğini Back-office'ten devre dışı bırakmalısınız. Smarty önbelleğini devre dışı bırakmak için
Back-Office> Gelişmiş Parametreler > Performans> Akıllı önbellekleme seçeneğini "Hayır" olarak ayarlayın.

1)Hata ayıklama modunu etkinleştirmek için aşağıdaki adımları izleyin:
  • Arka Ofis> Gelişmiş Parametreler> Performans
  • Hata Ayıklama Modu Bölümünde “Hata Ayıklama modu” seçeneğini Evet olarak ayarlayın.
  • Değişiklikleri uygulamak için “Kaydet” düğmesine tıklayın .
2)Hata ayıklama modunu etkinleştirmek için (Hata bildirme) aşağıdaki adımları manuel olarak izleyin:
  • FTP sunucunuza bağlanın Arka Ofis> Gelişmiş Parametreler>Performans
  • PrestaShop kök dizininizi açın.
  • Git “config / defines.inc.php” dosyası ve açın ve aşağıdaki kodu bulun:1



    if (!defined('_PS_MODE_DEV_')) {
    define('_PS_MODE_DEV_', false);
    }
    Şununla değiştir:

    if (!defined('_PS_MODE_DEV_')) {
    define('_PS_MODE_DEV_', true);
    }
  • Şimdi Değişiklikleri kaydedin ve siteyi yenileyin.