19.04 Disco Sorunları - R10.net
15
Bildirimler TÜMÜNÜ OKUNDU SAY
Yükleniyor, lütfen bekleyiniz..
Giriş Yap Kayıt Ol
  • 30-06-2020, 12:14:33
    #1
    Merhaba,

    19.04 ile ilgili paket kurulumları ve güncellemeler konusunda sorun yaşıyorum. Sunucuda NGINX kullanıyorum. En çok canımı sıkan farklı php sürümleri kullanamıyor olmam. Gerekli ppa eklemelerini yaptığım halde php5.6-fpm kurmak istediğimde aşağıdaki hatayı alıyorum.

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package php5.6-fpm
    E: Couldn't find any package by glob 'php5.6-fpm'
    E: Couldn't find any package by regex 'php5.6-fpm'
    5.6 kurmak istediğimde:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Note, selecting 'php5.6-json' for regex 'php5.6'
    Note, selecting 'php5.6-common' for regex 'php5.6'
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    apt-get update ve apt-get upgrade sonuçları

    apt-get update && apt-get upgrade
    Hit:1 http://ppa.launchpad.net/ondrej/php/ubuntu disco InRelease
    Hit:2 http://old-releases.ubuntu.com/ubuntu disco InRelease
    Hit:3 http://old-releases.ubuntu.com/ubuntu disco-updates InRelease
    Hit:4 http://old-releases.ubuntu.com/ubuntu disco-backports InRelease
    Hit:5 http://old-releases.ubuntu.com/ubuntu disco-security InRelease
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Bu da ondrej ppa list çıktısı


    deb http://ppa.launchpad.net/ondrej/php/ubuntu disco main
    deb-src http://ppa.launchpad.net/ondrej/php/ubuntu disco main
    İşletim sistemine çok hakim olmadığımdan tereddütte kaldım. Bu sorunu versiyon yükselterek ya da farklı bir yolla çözebilir miyim? Eğer versiyon yükseltmem gerekiyorsa sunucudaki dosyaları kaybetmeden versiyon yükseltebilir miyim?

    Eğer fresh kurulum yapmam gerekiyor ise yedekleme ve geri kurulum için nasıl bir yol izlemeliyim?

    Yardımcı olacak arkadaşlara şimdiden teşekkür ederim.
  • 30-06-2020, 12:19:30
    #2
    sanırım kullandığınız yazılımdan dolayı php 5.6'yı tercih ediyorsunuz.

    php7'yi desteklemiyor mu?
    -> jenerik domain nedir? ne değildir? - jenerikler.com
  • 30-06-2020, 12:21:40
    #3
    Ppa eklediginizi yeni gördüm php 5.6 kurulumu yapıldı mi
    "Memati öldü be Ustaa"
  • 30-06-2020, 12:29:51
    #4
    kavas adlı üyeden alıntı
    sanırım kullandığınız yazılımdan dolayı php 5.6'yı tercih ediyorsunuz.

    php7'yi desteklemiyor mu?
    Maalesef bazı yazılımlar desteklemiyor. PHP 7.1 kurulu fakat aynı sorun üst sürümler içinde geçerli. Yani 7.2 ya da 7.3 te kuramıyorum.

    M3M4Ti adlı üyeden alıntı
    Ppa eklediginizi yeni gördüm php 5.6 kurulumu yapıldı mi
    PHP 5.6 da kuramıyorum hocam. Konuda paylaşmıştım çıktısını.