Aspire
Koineks
  • 30-07-2016, 18:53:18
    #1
    1/2
    Merhaba,

    Elimde bir excel tablosu var. Sürekli elle girdiğimiz. Onu otomatikleştirmek istiyorum.

    Şu anda işin içinden çıkamadığım 2 şey var:

    1. Sorunum

    Şimdi B2 satırında toplam yemek sayım var.
    B3'te de Yemeklerin %50'si
    B4'te Yemeklerin %35'i
    B5'te de yemeklerin %15'i var.

    Yemek sayısı küsüratlı olmayacağına göre yuvarlama yapmam lazım. 0.5 ve üzerini 1 üst sayıya, altını bi alt sayıya yuvarlıyorum Hücreleri Biçimlendir > Sayı > Ondalık basamak sayısı 0 olacak şekilde. Yani B3'e B2*0,5 , B4'e B2*0,35 yazıyorum. B5'e de =B2-(B3+B4) yazıyorum. Sorunum da şu ki: B3, B4 hücrelerinde ondalık sayı olduğu ve yukarı yuvarladığı zaman en alttaki hücreyi de yuvarlıyo ve B3 B4 ve B5 hücrelerini toplayınca B2 yani toplam tabak sayısından fazla cıkıyo. Özetleyecek olursam 20 tane yemeğim var diyelim 10'u kırmızı et 6'sı tavuk 5'i makarna çıkıyo. Toplam 20 yemeğin yüzdelerini alıp yuvarlayınca 21 yemek çıkıyor yani bilmem anlatabildim mi. Bunu nasıl çözebilirim ?

    İkinci soruna gelecek olursak:

    B2 B3 B4 ve B5 hücrelerini düşünelim. İstiyorum ki B2'ye 2 yazıldığında B3, B4 ve B5'e 1 yazsın. Ama B2'ye 4 yazıldığında B3'e 2 B4'e 5 B5'e 6 yazsın. Bunları benim ayarlamam ve böyle bi şey yapmam mümkün mü?
    "Zihin fukara olunca, akıl ukala olurmuş."
  • Sponsor Reklam
  • 30-07-2016, 19:15:07
    #2
    1/2
    Eğer pazartesi sabahına kadar çözüm gelmezse pm atın çözelim
  • 30-07-2016, 19:23:00
    #3
    1/2
    amiral79 adlı üyeden alıntı
    Eğer pazartesi sabahına kadar çözüm gelmezse pm atın çözelim
    Teşekkürler hocam ilginiz için.
    "Zihin fukara olunca, akıl ukala olurmuş."
  • 30-07-2016, 20:39:33
    #4
    1/2
    1. soru

    B3:
    =TAMSAYI(B$2/2)
    B4:
    =TAMSAYI(B$2*35/100)
    B5:
    Alıntı
    =B$2-B$3-B$4


    2. SORU: Sadece dediğinizi karşılar başka sayıları boş döndürür.

    B3:
    =EĞER(B2=2;1;EĞER(B2=4;2;""))
    B4:
    =EĞER(B2=2;1;EĞER(B2=4;5;""))
    B5:
    =EĞER(B2=2;1;EĞER(B2=4;6;""))

    Patoloji Uzmanı

  • 30-07-2016, 22:19:09
    #5
    1/2
    metinciris adlı üyeden alıntı
    1. soru

    B3:
    =TAMSAYI(B$2/2)
    B4:
    =TAMSAYI(B$2*35/100)
    B5:




    2. SORU: Sadece dediğinizi karşılar başka sayıları boş döndürür.

    B3:
    =EĞER(B2=2;1;EĞER(B2=4;2;""))
    B4:
    =EĞER(B2=2;1;EĞER(B2=4;5;""))
    B5:
    =EĞER(B2=2;1;EĞER(B2=4;6;""))


    Hocam öncelikle teşekkür ederim. İnternette biraz araştırma yaptım da 2. soru için Makro olayında bütün sütunu istenilen sabite göre çekebiliyomuşuz galiba. Şimdi ben başka bi sayfada tablo yapsam ve sabit olacak yerden seçme listesi çıksa ordan 2 seçilince diğer sayfadaki tablodan çekse daha kolay olmaz mı ? Yapılabilir mi öyle bi şey ? Çünkü yapmak istediğim şey şu: Düşünün ki elinizde bi tablo var 15 tane müşteriye göre 4 farklı yemek çeşidinden kaç tane çıkarmanız gerektiğini söylüyor.

    b1'e kaç müşteri geleceğini yazıyosunuz mesela b1'e 5 müşteri yazarsanız b2'de 3 tane et b3'de 2 tane tavuk b4'te 1 tane balık b5'te de 1 tane makarna yap yazıyo mesela. Bunun gibi 1'den 15'e kadar müşteri seçenekleri var. Yani kodla yazılmaya çalışılsa çok fazla olur gibi geldi bana. Ben tabloyu bi yere hazırlasam ordan çektirsem daha kolay olur sanki.


    1.Soru için verdiğiniz kodları anlayamadım. Kodlar ne anlama geliyor ?

    Bi de mesela b25 hücresi b24'ün %50'sini alıyo. Verdiğiniz formülü %50'sini almış halinin içine nasıl yerleştirebilirim ?

    --R10.NET; Flood Engellendi -->-> Yeni yazılan mesaj 21:40:05 -->-> Daha önceki mesaj 21:27:36 --

    Daha açıklayıcı olması açısından bahsettiğim tablo bu: http://prntscr.com/bzjpp0

    Bu tablodaki sayılara göre buradaki tablonun sarı kısmının dolmasını istiyorum: http://prntscr.com/bzjq1t

    Yeşil kısım da ilk mesajda belirttiğim 1. soru. Toplam müşteri sayısı 50, tost sayısı yarısı 25, sandviç sayısı %35'i yani 17.5 ama 17.5 sandviç diye bi şey olmayacağı için bu yuvarlanacak. Yuvarlandığında 18 olacak doğal olarak. Makarna sayısını da toplam tost ve sandviç sayılarından toplam müşteri sayısı çıkartılarak hesaplansın istiyorum yani =Müşteri sayısı-(Tost sayısı + Sandviç) yapıyorum. Ama Sandviçi 1 yukarı yuvarladığı için ama aslında küsüratlı olduğu için makarna sayısı da küsüratlı ve bir üste yuvarlanmış oluyo. 1 fazla yemek oluyo.

    --R10.NET; Flood Engellendi -->-> Yeni yazılan mesaj 22:19:09 -->-> Daha önceki mesaj 21:40:05 --

    Ekleme: 1. Sorunumu @metinciris hocam sağolsun hallettim sanırım. Şimdi 2. konu kaldı bi tek.
    "Zihin fukara olunca, akıl ukala olurmuş."
  • 30-07-2016, 22:21:52
    #6
    1/2
    " Toplam müşteri sayısı 50, tost sayısı yarısı 25, sandviç sayısı %35'i yani 17.5 ama 17.5 sandviç "
    yarısı 25, burada ikiye böl ve tam sayıya yuvarla =TAMSAYI(B$2/2)
    sandviç 17.5, burada %35'i tam sayıya yuvarla yaptım =TAMSAYI(B$2*35/100)
    %15 en son kalanı toplamdan çıkararak buldum. Çünkü %50 ve %35 tam sayı çıkmayabilir. Her üçün toplamı %100 etsin diye. =B$2-B$3-B$4

    http://prntscr.com/bzjpp0 anlayamadım. Et sayısı kaçsa tavuk, balık, makarna ona göre mi düzenleniyor? Sanki hepsi elle yazılmış gibi. Değişken hangisi, hangileri değişiyor anlayamadım.



    edit:
    2. soru için
    yemek menülerini başka sayfaya yazın. Her gün farklı menü olabilir.
    Her menünün bir numarası olabilir.
    Müşteri sayfasında müşteri bir menü numarasını yazar. Formüller kolay olur da tam anlayamadım



    edit: Konuya sürekli post kasılmasın diye

    Ekran alıntının üzerine elle yazsanız nasıl bir formüle ihtiyaç olduğunu. Konuya bakıyorum @CNMRCN;


    edit: Sorun çözüldü sanırım. problem olursa imzamdaki linkten bana ulaşabilirsiniz.

    Patoloji Uzmanı

  • 30-07-2016, 22:34:33
    #7
    1/2
    metinciris adlı üyeden alıntı
    " Toplam müşteri sayısı 50, tost sayısı yarısı 25, sandviç sayısı %35'i yani 17.5 ama 17.5 sandviç "
    yarısı 25, burada ikiye böl ve tam sayıya yuvarla =TAMSAYI(B$2/2)
    sandviç 17.5, burada %35'i tam sayıya yuvarla yaptım =TAMSAYI(B$2*35/100)
    %15 en son kalanı toplamdan çıkararak buldum. Çünkü %50 ve %35 tam sayı çıkmayabilir. Her üçün toplamı %100 etsin diye. =B$2-B$3-B$4

    http://prntscr.com/bzjpp0 anlayamadım. Et sayısı kaçsa tavuk, balık, makarna ona göre mi düzenleniyor? Sanki hepsi elle yazılmış gibi. Değişken hangisi, hangileri değişiyor anlayamadım.
    Hocam 1. sorunu sayenizde çözdüm çok sağolun. Anlayamadığınız kısmı da ben anlatamadım sanırım. Dediğiniz gibi elle girilmiş şeyler zaten. Belli bir değişkeni yok yani, aralarında bi oran vs. yok. Tamamen önceden belirlenmiş bir tablo.
    "Zihin fukara olunca, akıl ukala olurmuş."